Сейчас на форуме: vsv1, asfa, tyns777 (+3 невидимых)

 [email protected] —› Вопросы новичков —› Проблемы с DriverStudio (SoftIce), все вопросы сюда!
<< . 1 . 2 . 3 . 4 . 5 . 6 . 7 . 8 . 9 . 10 ... 18 . 19 . >>
Посл.ответ Сообщение


Ранг: 793.4 (! !), 568thx
Активность: 0.740
Статус: Участник
Шаман

Создано: 06 октября 2006 01:09 · Поправил: Модератор
· Личное сообщение · #1

Так как вопросы по SoftIce поднимаются постоянно, и зачастую они уже поднимались ранее, я решил создать этот топик. Возможно в нем накопится достаточно информации, чтобы не поднимать более эти вопросы и станет чем то вроде FAQ для новичков.

Но для начала все же попробуйте воспользоваться поиском!
14 стр. этой темы одним листом:
http://exelab.ru/f/files/db0f_08.02.2008_CRACKLAB.rU.tgz

PS Вопросы по работе с SoftIce (команды и т.д.) сюда не задавайте!

-----
Yann Tiersen best and do not fuck





Ранг: 283.6 (наставник), 56thx
Активность: 0.130
Статус: Участник
Author of GeTaOEP

Создано: 19 декабря 2006 06:14
· Личное сообщение · #2

USSR
Какая ОС??
Посмотри тут,но дочитай топик до конца.
lexer666 пишет:
может это быть из-за установленых когда-то Daemon Tools?

...может.
В Device Manager необходимо проверить присутствует ли среди Non-Plug and Play Drivers (View -> Show hidden devices) устройство sptd.sys.
Если да,то можно отключить его(перезагрузка обязательна),а потом и попытаться удалить его(перезагрузка опять-таки обязательна).

-----
the Power of Reversing team




Ранг: 1.7 (гость)
Активность: 0=0
Статус: Участник

Создано: 19 декабря 2006 07:14
· Личное сообщение · #3

SIce из DS 3.2
После запуска пишет что служба успешно запущена, но сразу виснет
Патчи применял



Ранг: 3.3 (гость)
Активность: 0=0
Статус: Участник

Создано: 19 декабря 2006 09:27
· Личное сообщение · #4

Как вручную удалить то, что оставил после себя инсталлер Алкоголя, я забыл посмотреть, когда он у меня был, какие там библиотечки?



Ранг: 0.4 (гость)
Активность: 0=0
Статус: Участник

Создано: 20 декабря 2006 07:23
· Личное сообщение · #5

ida показывает в dll наличие функций экспорта вида:
OnGame::ClassName::FunctionName(bool)
как в softIce поставить бряк на это?
в winice.dat
добавил
Exp=PathDllName.dll
пробовал:
bpx FunctionName
bpx OnGame::ClassName::FunctionName
пишет Symbol not defined....



Ранг: 41.1 (посетитель)
Активность: 0.030
Статус: Участник

Создано: 21 декабря 2006 01:32
· Личное сообщение · #6

Это полная
Вот что после нажатия стрл-Д. Пропобал разные Сайсы, патчи и т.д. Может надо еще какойнибуть патч на видео? у меня 2x AMD Opteron, ASUS K8N-DRE, 4GB RAM, GeForce 6600GT, и WinXP-32-SP2 для тестов. Ну почему оно не пашет?

f841_21.12.2006_CRACKLAB.rU.tgz - to_forum.rar



Ранг: 41.1 (посетитель)
Активность: 0.030
Статус: Участник

Создано: 21 декабря 2006 01:43 · Поправил: Spry
· Личное сообщение · #7

Забыл сказать, на всякий пожарный, у меня монитор ТФТ через DVI подключен.
На nvidia 6600gt при выборе универсального драйвера все работает как часы,пока не лезу в айс с консоли (видео режим текст - 80x25, FAR к примеру). После выхода обратно (SVGA) при попытке вызвать отладчик комп виснет намертво.



Ранг: 1.7 (гость)
Активность: 0=0
Статус: Участник

Создано: 21 декабря 2006 05:26
· Личное сообщение · #8

ТОварищи, ну хоть чем ниьудь помогите а?



Ранг: 0.4 (гость)
Активность: 0=0
Статус: Участник

Создано: 21 декабря 2006 06:19
· Личное сообщение · #9

что-то ветераны не заглядывают сюда... пошел читать доки....



Ранг: 4.6 (гость)
Активность: 0=0
Статус: Участник

Создано: 21 декабря 2006 12:28
· Личное сообщение · #10

DillerInc спасибо за совет, только такой библиотеки нет, может какая-нибудь из следующих (в аттаче список) , если не лень гляньте. Спасибо

765f_21.12.2006_CRACKLAB.rU.tgz - drivers.jpg




Ранг: 283.6 (наставник), 56thx
Активность: 0.130
Статус: Участник
Author of GeTaOEP

Создано: 22 декабря 2006 03:38
· Личное сообщение · #11

lexer666
Хм...так будет трудно сказать,что ему мешает...
Дело в том,что третий DT,по-моему,не использовал этот драйвер(sptd).Его использование началось с четвёртой версии,где и начались проблемы с отладчиком.А вообще при конфликте с sptd выдаётся сообщение об ошибке с номером 31 -- "типа,присоединённое устройство не работает...".
Поэтому в твоём случае может быть что-то другое.

-----
the Power of Reversing team




Ранг: 2.5 (гость)
Активность: 0.010
Статус: Участник

Создано: 28 декабря 2006 10:32
· Личное сообщение · #12

Подскажите, пожалуйста, какие библиотечки оставляет за собой алкоголь?




Ранг: 283.6 (наставник), 56thx
Активность: 0.130
Статус: Участник
Author of GeTaOEP

Создано: 29 декабря 2006 07:04
· Личное сообщение · #13

Moonglow
Если Алкоголь выше версии 1.9.5.3105,то речь идёт не о "библиотечках",а о драйвере sptd.sys,который и надо удалить.Смотри в начале этой страницы мой пост.

-----
the Power of Reversing team




Ранг: 2.5 (гость)
Активность: 0.010
Статус: Участник

Создано: 31 декабря 2006 06:21
· Личное сообщение · #14

DillerInc Спасибо, про версию ты угадал.



Ранг: 7.9 (гость)
Активность: 0=0
Статус: Участник

Создано: 07 января 2007 01:38
· Личное сообщение · #15

Как нормально настроить айс под VMware,а то она жутко глючит. раньше делал, помню где-то в конфиге поменять чистоту обновления экрана и ещё с мышью что-то. щяс инфу потерял, и напомню как и где что прописывать.



Ранг: 0.2 (гость)
Активность: 0=0
Статус: Участник

Создано: 08 января 2007 11:52
· Личное сообщение · #16

Есть ноут HP nx6310 rh349ea, проц - Intel Core 2 Duo T5600, OS - WinXP 64 SP1.

Пытался ставить на него DriverStudio. При установке DriverStudio 3.2 сначала запускаю инсталлер из папки Targetx64, перезагружаюсь, далее Setup.exe из папки Setup. И вот здесь выдается ошибка:

To install Compuware DriverStudio 3.2 target drivers and components on 64-bit operating systems, run the target installer in the Target64 directory on the CD-ROM.

Аналогичная ситуация и с 3.1

Может кто встречался с такой ситуацией, помогите, пожалуйста.



Ранг: 25.8 (посетитель)
Активность: 0.020
Статус: Участник

Создано: 10 января 2007 12:13
· Личное сообщение · #17

Хотел себе установить SoftICE. Значит переустановил себе винду (давно уже хотел), поставил себе XP sp2. Установил только драйвера на мамку со встроенной видюхой и первым делом Сайс (SoftICE 4.05 WinNT), по статье Bad_guy'a, файлы перекопировал (ntice.sys и siwvid.sys), файлик Winice.dat подредактировал как положено, запускаю файл ntice.bat и мне выдаёт такой синий экран смерти, тока с надписями, я по-англицки не бум-бум, так что толку от этих надписей нету, (экран я сфоткал на мабилу, он приложен), из этого экрана можно выйти только методом трёх пальцев, после нажатия сего, мой ПК перезагружается... Что ни пробовал - не получается. Помогите плз, а то я уже замахался перезагружаться...
И заодно, дайте плз серийник на SoftICE из Compuware DriverStudio 3.2. У Bad_guy'a в статье на DriverStudio 3.1 есть, но он на 3.2 (по крайней мере у меня) не пашет. Подкиньте плз...

6c59_10.01.2007_CRACKLAB.rU.tgz - Синий экран смерти.jpg



Ранг: 2.5 (гость)
Активность: 0.010
Статус: Участник

Создано: 10 января 2007 15:05
· Личное сообщение · #18

[poly] glot, у меня проблема очень похожа. Только я умудрился со злости мбр и файловую систему уронить ;), переставил обе винды и линуха, СофтАйс устанавливал на XPSP2Rus, все по статье.
Запускаю, работает.. Вот только при попытке перезагрузки система вылетает, скорее всего, надо в winice.dat что-то обратно закомментировать.
На твоем "скрине" ничего не видно, но в первых строчках говорилось что-то про модель памяти, у меня - ругается на несовместимость оборудования и просит откатить все драйвера.



Ранг: 2.0 (гость)
Активность: 0=0
Статус: Участник

Создано: 10 января 2007 23:43
· Личное сообщение · #19

Решил я начать пользоваться SoftIce. Какие только версии не скачивал, инструкциям всем следовал, но при запуске ntice.bat на мгновение вылетает досовское окно и ничего как будто и не было, та же проблема была потом в SoftIce 4.32. При всем этом он у меня стоял на manual и часть программ не запускалась именно из-за него.

Стоит у меня Windows XP SP2 (пробовал переставлять, не помогало).
До этого стол Daemon Tools, после удаления все равно не работает.
Файрвол при попытке запуска у меня отключен.
Видео - Radeon X800 GTO.

P.S.:Может он не контачит с 64-разрядным Athlon'ом.



Ранг: 495.3 (мудрец)
Активность: 0.30
Статус: Участник

Создано: 11 января 2007 14:40
· Личное сообщение · #20

Fokstrot пишет:
Может он не контачит с 64-разрядным Athlon'ом.

Прекрасно контачит если ось 32-битная.
Fokstrot пишет:
До этого стол Daemon Tools, после удаления все равно не работает.

Удалил просто анинсталом? Если так, то ещё нужно драйвер грохнуть ручками.
Теоретически на «чистую» XP SP1 или SP2, Home или Pro, должно встать без проблем.

Fokstrot пишет:
но при запуске ntice.bat на мгновение вылетает досовское окно и ничего как будто и не было

Это не ДОС’овское окно, а консоль. Важно знать, что там было написано.

-----
Всем привет, я вернулся




Ранг: 18.0 (новичок)
Активность: 0.020
Статус: Участник

Создано: 11 января 2007 15:52
· Личное сообщение · #21

В статье, по которой все на XP ставят айс все правильно, кроме одного - надо больше памяти давать айсу в настройках. Часто помогает с проблемами то, что можно первоначально указать запуск айса в автоматическом режиме (он это любит) а потом перевести в ручной. Я уже давно пользуюсь 3.2.7.
Устанавливал на SP-1. Однако, довольно быстро устал от постоянной необходимости при старте системы указывать - надо мне запуск студии или нет. К тому же, чтобы с айсом ничего не конфликтовало (по самым банальным причинам) я сделал у себя под крек отдельную систему (без файрвола, антивиря и т.п.) и когда мне это надо - устанавливаю ее из имеджа. Короче, все работает как надо. Только надо иметь ввиду, что когда станешь ставить символы отладочные - их надо обязательно брать из инета. То есть через соответствующую вкладку айса. Те наборы символов, что есть здесь - в разделе скачать пойдут далеко не для всех. Одинаковые по сборке системы встречаются редко. Когда будешь эти символы скачивать, возможно (я не смотрел за этим давно) потребуется поменять dll в этой вкладке айса. Уже давно, на форуме один хороший человек их давал. Я тогда на Ура эту проблему решил.



Ранг: 0.2 (гость)
Активность: 0=0
Статус: Участник

Создано: 13 января 2007 05:39
· Личное сообщение · #22

Вы уж уважте если такой вопрос уже задовался, я уже битый день перечитываю форум
Я начну сначала что-бы небыло вопросов:

1. Скачал совтICE где-то пол года назад (в то время FAQ для SP2 в *.pdf небыло) поставил, всё тыры пыры, делаю ресстарт, и рестарты начинают идти по кругу (азначает то что система неможет запустица из за ошибки) залезаю в настройки и атключаю автоматический рестарт при ошибке. Далее понимаю что ошибка вызвана софтISE`ом пытабсь зайти через SAFEMODE и удалить нафиг, но фишка в том что при загрузке SAFEMODE показывает оналогичнаю ошибку. Подключаю ноутбоок к компу и тупа всё удаляю через shift+del. Всё вроде ок. Но без софт айса...

Кофигурация компа:
Pentium 4 3.01
RAM: 2GB
Video: ATI readon x810 128mb
Win XP SP 2

А теперь вопрос:
1. Каким раком SOFTISE заблокировал SaveMode ? (точнее создал ошибку и в SM)
2. Чем вызвона ошибка запуска ОС ? (поясните, любые версии)

2. ВТорая часть, проходит пол года я заного скачеваю совтISE и нахожу там FAQ для SP 2. Делаю всё ВСЁ что там описано. Вот поставил запускаю и показывает С:/......./......./..../SoftIse/ - что то там локал старт
после чего мой камп умирает намертво нереагируя ненаодну команду. Только рестарт после которого всё нормально, запускаем ISE и он снова виснет. Гдето два рестарта и во время запуска ISE, начал появлятся синий экран с ошибкой и прзьбой рестарта.

Вопросы:
3. Как исправить ?
4. Почему дохнет камп ?
5. И как мне поставить ise ???

Зарание спасибо тому человеку который мне хоть в чём то поможет!



Ранг: 0.2 (гость)
Активность: 0=0
Статус: Участник

Создано: 13 января 2007 08:14
· Личное сообщение · #23

У меня проблема такая:
Устанавливаю, перегружаюсь, все работает. Кстати, запускаю через батник, в авторан не прописывается.
После второй перезагрузки дохнет. Не врубается, и все.
Версия: SoftIce_from_4_2_7_XP.



Ранг: 0.6 (гость)
Активность: 0=0
Статус: Участник

Создано: 17 января 2007 15:34 · Поправил: merin
· Личное сообщение · #24

Может у кого была такая проблема
Установил DriverStudio 3.2 казалось бы все нормально работает, но после
10 - 30 нажатий на F8 или F10 полное отключени клавиатуры ,
может у кого есть решение такой проблемы?




Ранг: 283.6 (наставник), 56thx
Активность: 0.130
Статус: Участник
Author of GeTaOEP

Создано: 18 января 2007 09:21
· Личное сообщение · #25

merin
Ну,бывает такое...только весьма редко.Бывает,что мышь умирает напрочь и оживает только когда выйдешь из отладчика.Решения не искал, т.к. редкое явление у меня.
Но ты можешь попробовать посмотреть настройки в DriverStudio Configuration --> Troubleshooting
Например,галка "Do not patch keyboard driver".
Только это всё на свой страх и риск, т.к. я лично не проверял.

-----
the Power of Reversing team




Ранг: 0.6 (гость)
Активность: 0=0
Статус: Участник

Создано: 18 января 2007 10:13
· Личное сообщение · #26

DillerInc

Пробовал,не помогает.
Устанавливал SoftIce 427,405 синий экран , тут вроди пошла и на тебе , бейся .....



Ранг: 495.3 (мудрец)
Активность: 0.30
Статус: Участник

Создано: 18 января 2007 13:46
· Личное сообщение · #27

merin пишет:
может у кого есть решение такой проблемы?

Мне помогает клавиша NumLock (off или On до входа Айс).
Но это не полное лечение. Я долго пытался убить эту проблему - до сих пор не вышло.
Никакие патчи не помогают, даже не пробуй.
Другие версии тоже вызывают глюки с клавой.
Один раз после переустановки вроде бы решилось, потом опять появилось, и хрен знает, в чём дело.
Если изменить скорость повтора в настройках винды - будет по стабильней, но это изврат полный.

-----
Всем привет, я вернулся




Ранг: 0.6 (гость)
Активность: 0=0
Статус: Участник

Создано: 18 января 2007 15:06
· Личное сообщение · #28

Bitfry пишет:
Если изменить скорость повтора в настройках винды - будет по стабильней, но это изврат полный.


Да ,есть такая буква , если увеличивать паузу повторов то держиться по-дольше, переустановил винду
XP Professional такая же беда, восстановил лицензионную HOME , и все на своих местах ,
может IRQ надо менять,у меня почему то вручную не меняется ,что делать уже не знаю , не могут два ядра мозги пудрить честному человеку?



Ранг: 1.7 (гость)
Активность: 0=0
Статус: Участник

Создано: 23 января 2007 06:07
· Личное сообщение · #29

Товарищи подскажите ,чё делать, если после 3бринта клава не... отвечает????



Ранг: -1.3 (гость)
Активность: 0=0
Статус: Участник

Создано: 24 января 2007 13:09 · Поправил: Teo
· Личное сообщение · #30

С SoftIce'ом у меня вот какая история: Установил SIce 4.05 всё как полагается. Запускаю ntice.bat всё как бы хорошо. Нажимаю Ctrl-D - работает, тока мышь здохла, закрываю окно и вижу что умирла не только мышь, а вся Wind'а! При нажатии Ctrl+Alt+Del - комп перезагружается. Подскажите в чём дело, почему комп виснет?




Ранг: 283.6 (наставник), 56thx
Активность: 0.130
Статус: Участник
Author of GeTaOEP

Создано: 24 января 2007 14:31
· Личное сообщение · #31

Teo пишет:
Подскажите в чём дело, почему комп виснет?

...небось на XP SP2 ставишь??
Неоднократно уже говорилось,что нечего всякое старьё устанавливать.
DS 3.2 -- это пробуй.

-----
the Power of Reversing team



<< . 1 . 2 . 3 . 4 . 5 . 6 . 7 . 8 . 9 . 10 ... 18 . 19 . >>
 [email protected] —› Вопросы новичков —› Проблемы с DriverStudio (SoftIce), все вопросы сюда!
Эта тема закрыта. Ответы больше не принимаются.
   Для печати Для печати