Сейчас на форуме: vsv1, asfa, tyns777 (+3 невидимых)

 [email protected] —› Вопросы новичков —› Проблемы с DriverStudio (SoftIce), все вопросы сюда!
<< 1 ... 9 . 10 . 11 . 12 . 13 . 14 . 15 . 16 . 17 . 18 . 19 . >>
Посл.ответ Сообщение


Ранг: 793.4 (! !), 568thx
Активность: 0.740
Статус: Участник
Шаман

Создано: 06 октября 2006 01:09 · Поправил: Модератор
· Личное сообщение · #1

Так как вопросы по SoftIce поднимаются постоянно, и зачастую они уже поднимались ранее, я решил создать этот топик. Возможно в нем накопится достаточно информации, чтобы не поднимать более эти вопросы и станет чем то вроде FAQ для новичков.

Но для начала все же попробуйте воспользоваться поиском!
14 стр. этой темы одним листом:
http://exelab.ru/f/files/db0f_08.02.2008_CRACKLAB.rU.tgz

PS Вопросы по работе с SoftIce (команды и т.д.) сюда не задавайте!

-----
Yann Tiersen best and do not fuck




Ранг: 0.9 (гость)
Активность: 0=0
Статус: Участник

Создано: 03 июня 2009 11:37
· Личное сообщение · #2

WebMoney Keeper Classic до 3.7.0.1. - новая защита?

ситуация такая же. тема закрыта, но ответа нет.

Вопрос: как вообще убрать сайс из системы, в частности, чтобы не грузился его драйвер при загрузке системы?




Ранг: 2014.5 (!!!!), 1278thx
Активность: 1.340.25
Статус: Модератор
retired

Создано: 03 июня 2009 17:18
· Личное сообщение · #3

Волшебная кнопочка анинсталл не помогает?



Ранг: 1.2 (гость)
Активность: 0=0
Статус: Участник

Создано: 12 июля 2009 21:18 · Поправил: Bomzheg
· Личное сообщение · #4

читал не весь топик, но большую часть.
поскольку на компе Windows XP SP3 пришлось поставить на виртуалку( MS Virtual PC) XP SP1 professional , SoftICE.4.27 даже запустился, но почему-то экран обновляется только когда перемещаю окно с виртуальной машиной. Поясню: если я ввожу какие-либо команды, то кажется, что ничего не поменялось, но если чуть сдвинуть окно с виртуалкой, то введённые символы отобразятся.
видюха: ATI Mobility Radeon X1600




Ранг: 2014.5 (!!!!), 1278thx
Активность: 1.340.25
Статус: Модератор
retired

Создано: 13 июля 2009 18:11
· Личное сообщение · #5

Хз, что с виртуал ПЦ, а на варе надо прописывать дополнительные команды в конфиг. Есть логичное предположение, что тут тоже. Гугли.



Ранг: 0.4 (гость)
Активность: 0=0
Статус: Участник

Создано: 23 июля 2009 15:03
· Личное сообщение · #6

Всем привет!
Поставил себе Driver Studio 3.2 полный пакет. После установки настроил SoftICE. Вроде бы все нормально, работает, но одна проблема после загрузки Айса комп через некоторое время виснет и работает только Ctrl+D.
У меня стоит Windows XP SP3. Сколько копался так и не нашел причину. Может действительно из-за этого файла osinfo.dat но там есть еще и osinfob.dat. Фиг его знает что там ему не нравится. Насколько я знаю Compuware прекратила разработку Айса да и походу всего пакета DriverStudio. На фтп у них уже пусто (я по поводу каталога outgoing/OsInfo). По ссылке озвученной в этом топике качаю Айс для 3-го пака, может заработает. Однако я думаю можно будет Айс из DriverStudio 3.2 до ума довести. Ведь так все работает надо бы разобраться в причине зависания разобраться. Кстати после установки я Айс сначала не настраивал (я имею ввиду строку инициализации(FAULTS OFF и др.), библиотеки) Айс запускался, но при этом комп вис сразу (опять же работал только айс), после настройки комп стал зависать через определенное время. В айсе при этом вместо кода исследуемой проги, выводились строки уведомляющие об каких-то предупреждениях и прочее барахло. Незнаю что это.




Ранг: 2014.5 (!!!!), 1278thx
Активность: 1.340.25
Статус: Модератор
retired

Создано: 23 июля 2009 17:09
· Личное сообщение · #7

Нет нормального айса для хр 3 сп, сколько раз ещё об этом написать надо. Вообще топ закрывать пора, айс умер, постов по делу нет.



Ранг: 0.4 (гость)
Активность: 0=0
Статус: Участник

Создано: 23 июля 2009 20:38
· Личное сообщение · #8

Скачал Айс по ссылке данной в этом топике. Поставил поверх Айса из Driver Studio. Все работает. Спасибо за ссылку. И за этот топик.



Ранг: 0.4 (гость)
Активность: 0=0
Статус: Участник

Создано: 30 июля 2009 16:54
· Личное сообщение · #9

Всем здравствуйте. Никак не могу решить проблему с работой SoftIce, после установки он просто не работает. При его запуске просто ничего не происходит. Пробовал разные версии вплоть до самой последней! При смене способов загрузки (manual и т.д.) "вешал" винду и перегруз, только с кнопки.

Теперь немного о системе:
- WindowsXP SP3
- Antivirus Kaspersky (вроде не ругается)
- USB клава и мышь.

! Стоял Alcohol 120%, но был удален. Насколько помню, при уснановке какой-то версии айса была попытка перезаписи ядра и установка была отменена!




Ранг: 568.2 (!), 465thx
Активность: 0.550.57
Статус: Участник
оптимист

Создано: 31 июля 2009 12:43
· Личное сообщение · #10

uckuHЧитай внимательно --> Link <--

-----
Чтобы правильно задать вопрос, нужно знать большую часть ответа. Р.Шекли.




Ранг: 0.6 (гость)
Активность: 0=0
Статус: Участник

Создано: 02 сентября 2009 15:42
· Личное сообщение · #11

А прочел одну статью автора Mozg-а взлом BlueFace, и он написал: "чтобы просмотреть содержимое памяти надо ввести символ " ? " в отладчике". Но когда я его ввел, то отладчик говорит, чтобы я воспользовался хелпером. Как посмотреть содержимое регистра в Soft Ice - е? Что мне для этого надо ввести?




Ранг: 2014.5 (!!!!), 1278thx
Активность: 1.340.25
Статус: Модератор
retired

Создано: 02 сентября 2009 16:00
· Личное сообщение · #12

Нормально работает команда ? И окно регистров там можно вывести. А ещё можно заглянуть в шапку, где написано: Вопросы по работе с SoftIce (команды и т.д.) сюда не задавайте!



Ранг: 0.8 (гость)
Активность: 0=0
Статус: Участник

Создано: 05 сентября 2009 00:49
· Личное сообщение · #13

Насколько я помню айс даже в WindowsXP SP2 не работает.




Ранг: 2014.5 (!!!!), 1278thx
Активность: 1.340.25
Статус: Модератор
retired

Создано: 05 сентября 2009 08:05
· Личное сообщение · #14

Плохо помнишь, в СП2 нормально работает.



Ранг: 0.6 (гость)
Активность: 0=0
Статус: Участник

Создано: 05 сентября 2009 16:53
· Личное сообщение · #15

Archer, не судите строго, если что. А куда мне задавать вопросы по командам в Ice? Отладчик не только под Sp2 работает, но и под SP3



Ранг: 129.0 (ветеран), 116thx
Активность: 0.060
Статус: Участник

Создано: 05 сентября 2009 23:41
· Личное сообщение · #16

chulat пишет:
А куда мне задавать вопросы по командам в Ice?

Отладчик SoftICE. Подробный справочник
rapidshare.com/files/123424243/Ayrapetyan.rar.html

-----
We do what we want because we can.




Ранг: 0.6 (гость)
Активность: 0=0
Статус: Участник

Создано: 07 сентября 2009 13:14
· Личное сообщение · #17

Verdizela, спасибо тебе. Сейчас скачаю



Ранг: 0.8 (гость)
Активность: 0=0
Статус: Участник

Создано: 06 ноября 2009 13:35
· Личное сообщение · #18

Корче нужно было недавно проинсталировать СофтАйс на два компа -
один на стационарный, а другой на ноутбук ACER Extensa 5620. На обоих Windows XP SP2.
Ну так вот, на стационарном всё прошло как и должно было пройти всё
без проблем работает, а на ноут ни в какую нехочет. Короче только ставлю его туда
(ещё даже зделать ничего неуспеваю) перезагружаю, дальше система негрузится и выбивает
вот такой синий экран.

rghost.ru/588012/image.png

После такого один выход, перезагрузка в защищённый режим и деинсталяция отладчика.
Пробовал разные версии SoftICE 4.05, SoftICE 4.27 из Compuware DriverStudio 2.7 всёравно
одна хрень.

Что делать?

P.S. где взять патч для видео под SoftICE 4.27? все ссылки битые



Ранг: 0.2 (гость)
Активность: 0=0
Статус: Участник

Создано: 06 ноября 2009 18:38
· Личное сообщение · #19

а софт айс работает под win xp x64 ??
я поставил вроде все норм но при запуске пишет что невозможна загрузить драйвера (error 1275)




Ранг: 2014.5 (!!!!), 1278thx
Активность: 1.340.25
Статус: Модератор
retired

Создано: 07 ноября 2009 13:41
· Личное сообщение · #20

Не работает он под х64.



Ранг: -3.6 (нарушитель)
Активность: 0=0
Статус: Участник

Создано: 12 ноября 2009 17:08
· Личное сообщение · #21

помогите, а версия SoftIce для OS Vista есть?
много читал искал, но в гугле ключивые слова дают полный бред




Ранг: 2014.5 (!!!!), 1278thx
Активность: 1.340.25
Статус: Модератор
retired

Создано: 12 ноября 2009 18:55
· Личное сообщение · #22

Нет



Ранг: 0.2 (гость)
Активность: 0=0
Статус: Участник

Создано: 11 января 2010 00:08
· Личное сообщение · #23

Здравствуйте, вопрос такого плана: У меня седьмой Винь, поставил софт айс, по ПДФ файлу, а оно не пашет, если не пашет, значит можно снести не боясь за систему? И есть ли аналог чтоб работал?




Ранг: 2014.5 (!!!!), 1278thx
Активность: 1.340.25
Статус: Модератор
retired

Создано: 11 января 2010 19:13
· Личное сообщение · #24

Видимо, можешь сносить. Ну можешь держать разный неработающий хлам на машине. А ещё неплохо перед установкой было поглядеть на список поддерживаемых систем. Аналог-windbg и syser. Последний работает не особо. Можешь варю на вм держать.




Ранг: 105.6 (ветеран), 36thx
Активность: 0.10
Статус: Участник

Создано: 26 января 2010 21:53
· Личное сообщение · #25

Проблема у меня не стандартная...
Работал раньше с олей, но какой-то добрый протектор мне её запорол.
Поставил ледяного но хрюшу SP2, потом обновил её до SP3. Айс всё ещё работает, запускается и не пишет ошибки, но, загрузившись в память, он через некоторое время подключается к какому-нибудь системному процессу(типа winlogon.exe) и винда стопорится... Айс продолжает работать. в boot сектор не пихал...
Неужели винда сама делает ошибки, чтобы никакие айсы её не отлаживали?????

Материнка GYGABYTE 8IE2004PL
прцессор Celeron 1.7 (типа пенька 4-ого)
386 MB оперативки
мышь и клава PS/2
Видюха ATI Radeon 9-ой серии 128 MB
Монитор 14"
Сетевая карта D-Link (локальная сеть)




Ранг: 2014.5 (!!!!), 1278thx
Активность: 1.340.25
Статус: Модератор
retired

Создано: 26 января 2010 22:30
· Личное сообщение · #26

Винда вообще не при чём. Ещё раз в 10-й напишу: работа на СП3 не гарантирована. Т.е. он может тупо не запуститься, может сдохнуть сразу, может через какое-то время. И вообще хрен знает что может сделать.




Ранг: 105.6 (ветеран), 36thx
Активность: 0.10
Статус: Участник

Создано: 27 января 2010 21:29
· Личное сообщение · #27

Спасибо, винда тут правда не причём, это просто маленькая драка винды и айса за мышу (прерывание E не очень хорошо обрабатывается)... Попытаюсь справится сам.



Ранг: 0.6 (гость)
Активность: 0=0
Статус: Участник

Создано: 25 февраля 2010 00:21
· Личное сообщение · #28

Здравствуйте
Никак не могу подружить сайс с вмварей.
Версия вари 5.5.3
Что делал: скачал si405wnt.rar, установил его, установил патч под сп2
пробовал инсталлировать вмваре тулз, на результате никак не сказалось.
Добавил в конфиг вари строки
vmmouse.present = FALSE
svga.maxFullscreenRefreshTick = 5
В обоих случаях (с тулзами и без) сайс либо выдаёт экран в полосочку, либо бсод
Хелп ми плиз




Ранг: 2014.5 (!!!!), 1278thx
Активность: 1.340.25
Статус: Модератор
retired

Создано: 25 февраля 2010 18:07
· Личное сообщение · #29

Какая ОС на варе? А поставить последние версии, как вари (в принципе, не критично), так и ДС (крайне желательно) не судьба?




Ранг: 105.6 (ветеран), 36thx
Активность: 0.10
Статус: Участник

Создано: 25 февраля 2010 20:18
· Личное сообщение · #30

=V=, тебе сайс для чего, может Syser'а хватит? он идёт почти везде...



Ранг: 0.6 (гость)
Активность: 0=0
Статус: Участник

Создано: 26 февраля 2010 00:02 · Поправил: =V=
· Личное сообщение · #31

Archer
хп сп2 без упдейтов, ставил ту версию потому как в интронетах есть мануал подробный от Бэдгая.
какая последняя версия?
Dart Sergius
дровишки вестимо(не свои), с олькой разобрался, идём на ядро
Сисер говорят глючный...
поставил 4.2.7, поправил реестр, после запуска также, экран в полосочку и виснет



<< 1 ... 9 . 10 . 11 . 12 . 13 . 14 . 15 . 16 . 17 . 18 . 19 . >>
 [email protected] —› Вопросы новичков —› Проблемы с DriverStudio (SoftIce), все вопросы сюда!
Эта тема закрыта. Ответы больше не принимаются.
   Для печати Для печати